import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"Sales_Rep_lookup__c\":(\"?)(?<Salerep>.*?)(\"?)*?,\"Opportunity__c\":(\"?)(?<Opptun>.*?)(\"?)*?,\"Project__c\":(\"?)(?<project>.*?)(\"?)\\}]\\}";
final String string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v43.0/sobjects/Contact/0031K00002q8BrXQAU\"},\"Id\":\"0031K00002q8BrXQAU\",\"Phone\":\"7032847786\",\"Sales_Rep_lookup__c\":\"a1J1K00000NLykQUAT\",\"Opportunity__c\":\"0061K00000eQXdIQAW\",\"Project__c\":\"a0h1K00000CQzHpQAL\"}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}