re = /"Sales_Rep_lookup__c":("?)(?<Salerep>.*?)("?)*?,"Opportunity__c":("?)(?<Opptun>.*?)("?)*?,"Project__c":("?)(?<project>.*?)("?)}]}/m
str = '{"searchRecords":[{"attributes":{"type":"Contact","url":"/services/data/v43.0/sobjects/Contact/0031K00002q8BrXQAU"},"Id":"0031K00002q8BrXQAU","Phone":"7032847786","Sales_Rep_lookup__c":"a1J1K00000NLykQUAT","Opportunity__c":"0061K00000eQXdIQAW","Project__c":"a0h1K00000CQzHpQAL"}]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end