import re
regex = re.compile(r"\"Sales_Rep_lookup__c\":(\"?)(?<Salerep>.*?)(\"?)*?,\"Opportunity__c\":(\"?)(?<Opptun>.*?)(\"?)*?,\"Project__c\":(\"?)(?<project>.*?)(\"?)}]}", flags=re.MULTILINE)
test_str = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v43.0/sobjects/Contact/0031K00002q8BrXQAU\"},\"Id\":\"0031K00002q8BrXQAU\",\"Phone\":\"7032847786\",\"Sales_Rep_lookup__c\":\"a1J1K00000NLykQUAT\",\"Opportunity__c\":\"0061K00000eQXdIQAW\",\"Project__c\":\"a0h1K00000CQzHpQAL\"}]}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")