#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)src="([^">]+(_images\\[\w\s]+\.(jpg|bmp|png|gif)))""
Local $sString = "" & @CRLF & _
"<TR>" & @CRLF & _
"<TD class=LabelBG noWrap></TD>" & @CRLF & _
"<TD class=LabelBG style="WIDTH: 5px"></TD>" & @CRLF & _
"<TD class=DataTextBG><SPAN style="OVERFLOW: hidden"><IMG border=0 src="C:\Users\eduardo\Desktop\Documentacion\Proceso Compras Nacionales\_images\ORDEN DE COMPRA.jpg" width=528> </SPAN></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE>" & @CRLF & _
"<P> </P><!--DATOS - Caracteristicas del Documento-->" & @CRLF & _
"<H3>Caracteristicas del Documento</H3>" & @CRLF & _
"<TABLE height=1 cellSpacing=0 width="100%" border=0>" & @CRLF & _
"<TBODY>" & @CRLF & _
"<TR>" & @CRLF & _
"<TD vAlign=top>" & @CRLF & _
"<UL>" & @CRLF & _
"<LI class=TextRow>Proceso "Compras Nacionales" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")