re = /src="([^">]+(_images\\[\w\s]+\.(jpg|bmp|png|gif)))"/i
str = '
<TR>
<TD class=LabelBG noWrap></TD>
<TD class=LabelBG style="WIDTH: 5px"></TD>
<TD class=DataTextBG><SPAN style="OVERFLOW: hidden"><IMG border=0 src="C:\\Users\\eduardo\\Desktop\\Documentacion\\Proceso Compras Nacionales\\_images\\ORDEN DE COMPRA.jpg" width=528> </SPAN></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE>
<P> </P><!--DATOS - Caracteristicas del Documento-->
<H3>Caracteristicas del Documento</H3>
<TABLE height=1 cellSpacing=0 width="100%" border=0>
<TBODY>
<TR>
<TD vAlign=top>
<UL>
<LI class=TextRow>Proceso "Compras Nacionales" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end