use strict;
my $str = '
<TR>
<TD class=LabelBG noWrap></TD>
<TD class=LabelBG style="WIDTH: 5px"></TD>
<TD class=DataTextBG><SPAN style="OVERFLOW: hidden"><IMG border=0 src="C:\\Users\\eduardo\\Desktop\\Documentacion\\Proceso Compras Nacionales\\_images\\ORDEN DE COMPRA.jpg" width=528> </SPAN></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE>
<P> </P><!--DATOS - Caracteristicas del Documento-->
<H3>Caracteristicas del Documento</H3>
<TABLE height=1 cellSpacing=0 width="100%" border=0>
<TBODY>
<TR>
<TD vAlign=top>
<UL>
<LI class=TextRow>Proceso "Compras Nacionales" ';
my $regex = qr/src="([^">]+(_images\\[\w\s]+\.(jpg|bmp|png|gif)))"/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}