const regex = /src="([^">]+(_images\\[\w\s]+\.(jpg|bmp|png|gif)))"/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src="([^">]+(_images\\\\[\\w\\s]+\\.(jpg|bmp|png|gif)))"', 'ig')
const str = `
<TR>
<TD class=LabelBG noWrap></TD>
<TD class=LabelBG style="WIDTH: 5px"></TD>
<TD class=DataTextBG><SPAN style="OVERFLOW: hidden"><IMG border=0 src="C:\\Users\\eduardo\\Desktop\\Documentacion\\Proceso Compras Nacionales\\_images\\ORDEN DE COMPRA.jpg" width=528> </SPAN></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE>
<P> </P><!--DATOS - Caracteristicas del Documento-->
<H3>Caracteristicas del Documento</H3>
<TABLE height=1 cellSpacing=0 width="100%" border=0>
<TBODY>
<TR>
<TD vAlign=top>
<UL>
<LI class=TextRow>Proceso "Compras Nacionales" `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}