// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)src="([^">]+(_images\\[\w\s]+\.(jpg|bmp|png|gif)))""#).unwrap();
let string = "
<TR>
<TD class=LabelBG noWrap></TD>
<TD class=LabelBG style=\"WIDTH: 5px\"></TD>
<TD class=DataTextBG><SPAN style=\"OVERFLOW: hidden\"><IMG border=0 src=\"C:\\Users\\eduardo\\Desktop\\Documentacion\\Proceso Compras Nacionales\\_images\\ORDEN DE COMPRA.jpg\" width=528> </SPAN></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE>
<P> </P><!--DATOS - Caracteristicas del Documento-->
<H3>Caracteristicas del Documento</H3>
<TABLE height=1 cellSpacing=0 width=\"100%\" border=0>
<TBODY>
<TR>
<TD vAlign=top>
<UL>
<LI class=TextRow>Proceso \"Compras Nacionales\" ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}