# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d\K(?=(?:\d{3})+\b)/./gm;t' <<< "$items = array(
\"Receive 10010 from John\",
\"Send 1503000 to Jane\",
\"Receive 589 from Andy\",
\"Send 3454 to Mary\"
);"