import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d\\K(?=(?:\\d{3})+\\b)";
final String string = "$items = array(\n"
+ " \"Receive 10010 from John\",\n"
+ " \"Send 1503000 to Jane\",\n"
+ " \"Receive 589 from Andy\",\n"
+ " \"Send 3454 to Mary\"\n"
+ ");";
final String subst = ".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}