# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d\K(?=(?:\d{3})+\b)"
test_str = ("$items = array(\n"
" \"Receive 10010 from John\",\n"
" \"Send 1503000 to Jane\",\n"
" \"Receive 589 from Andy\",\n"
" \"Send 3454 to Mary\"\n"
");")
subst = "."
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.