#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d\K(?=(?:\d{3})+\b)"
Local $sString = "$items = array(" & @CRLF & _
" "Receive 10010 from John"," & @CRLF & _
" "Send 1503000 to Jane"," & @CRLF & _
" "Receive 589 from Andy"," & @CRLF & _
" "Send 3454 to Mary"" & @CRLF & _
");"
Local $sSubst = "."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)