re = /\d\K(?=(?:\d{3})+\b)/m
str = '$items = array(
"Receive 10010 from John",
"Send 1503000 to Jane",
"Receive 589 from Andy",
"Send 3454 to Mary"
);'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result