#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)\n(.*)\n(.*)\n(.*)\n(.*)\n(.*)\n(.*)"
Local $sString = "Jane Doe" & @CRLF & _
"Sales manager" & @CRLF & _
"Test Company LLC 15" & @CRLF & _
"Example Street" & @CRLF & _
"Albany NY 12208" & @CRLF & _
"jane@test-company.com" & @CRLF & _
"www.test-company.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")