using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\n(.*)\n(.*)\n(.*)\n(.*)\n(.*)\n(.*)";
string input = @"Jane Doe
Sales manager
Test Company LLC 15
Example Street
Albany NY 12208
jane@test-company.com
www.test-company.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}