re = /(.*)\n(.*)\n(.*)\n(.*)\n(.*)\n(.*)\n(.*)/m
str = 'Jane Doe
Sales manager
Test Company LLC 15
Example Street
Albany NY 12208
jane@test-company.com
www.test-company.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end