#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d+\s*?(?:lac|crs?|k)\."
Local $sString = "it should not match this65 lac and this 55 lacand this87lacdsdsa" & @CRLF & _
"" & @CRLF & _
"should match 76 lac. nd 7 cr. including . It shoudl match 78 lac and 74 crs as well"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")