using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d+\s*?(?:lac|crs?|k)\.";
string input = @"it should not match this65 lac and this 55 lacand this87lacdsdsa
should match 76 lac. nd 7 cr. including . It shoudl match 78 lac and 74 crs as well";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}