re = /\b\d+\s*?(?:lac|crs?|k)\./m
str = 'it should not match this65 lac and this 55 lacand this87lacdsdsa
should match 76 lac. nd 7 cr. including . It shoudl match 78 lac and 74 crs as well'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end