package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+\s*?(?:lac|crs?|k)\.`)
var str = `it should not match this65 lac and this 55 lacand this87lacdsdsa
should match 76 lac. nd 7 cr. including . It shoudl match 78 lac and 74 crs as well`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}