#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$\d{1,3}(?:(?:[,.]\d)? (?:[MmBb]illion|thousand)|[,.]\dM|,\d{3})\b"
Local $sString = "Only $5.6 million plus change" & @CRLF & _
"Less than $4,1 billion to date" & @CRLF & _
"$8,1M" & @CRLF & _
"$6.3M" & @CRLF & _
"$333,333" & @CRLF & _
"$2 Million" & @CRLF & _
"$5 Billion" & @CRLF & _
"$3billion" & @CRLF & _
"$8.1 M" & @CRLF & _
"$333,3333" & @CRLF & _
"$3333,333" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")