$re = '/\$\d{1,3}(?:(?:[,.]\d)? (?:[MmBb]illion|thousand)|[,.]\dM|,\d{3})\b/m';
$str = 'Only $5.6 million plus change
Less than $4,1 billion to date
$8,1M
$6.3M
$333,333
$2 Million
$5 Billion
$3billion
$8.1 M
$333,3333
$3333,333
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);