import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\d{1,3}(?:(?:[,.]\\d)? (?:[MmBb]illion|thousand)|[,.]\\dM|,\\d{3})\\b";
final String string = "Only $5.6 million plus change\n"
+ "Less than $4,1 billion to date\n"
+ "$8,1M\n"
+ "$6.3M\n"
+ "$333,333\n"
+ "$2 Million\n"
+ "$5 Billion\n"
+ "$3billion\n"
+ "$8.1 M\n"
+ "$333,3333\n"
+ "$3333,333\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}