// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\$\d{1,3}(?:(?:[,.]\d)? (?:[MmBb]illion|thousand)|[,.]\dM|,\d{3})\b").unwrap();
let string = "Only $5.6 million plus change
Less than $4,1 billion to date
$8,1M
$6.3M
$333,333
$2 Million
$5 Billion
$3billion
$8.1 M
$333,3333
$3333,333
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}