using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\d{1,3}(?:(?:[,.]\d)? (?:[MmBb]illion|thousand)|[,.]\dM|,\d{3})\b";
string input = @"Only $5.6 million plus change
Less than $4,1 billion to date
$8,1M
$6.3M
$333,333
$2 Million
$5 Billion
$3billion
$8.1 M
$333,3333
$3333,333
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}