package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)20(?:09|1\d)`)
var str = `2008
2009
2010
2015
2019
2020`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}