$re = '/20(?:09|1\d)/m';
$str = '2008
2009
2010
2015
2019
2020';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);