const regex = /20(?:09|1\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('20(?:09|1\\d)', 'gm')
const str = `2008
2009
2010
2015
2019
2020`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}