import re
regex = re.compile(r"20(?:09|1\d)", flags=re.MULTILINE)
test_str = ("2008\n"
"2009\n"
"2010\n"
"2015\n"
"2019\n"
"2020")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")