package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)MOVE.*\n?.*VALIDER.*\n?.*F5`)
var str = `Move 'VALIDER LA DEMANDE REGU INIT ARTICLE & MAJ TARIF P16910000
017900- 'AR F5' to FSOV51-MESSAG
Move 'DEMANDE REGU TRAITEE, F6 POUR FORCER LA DE16710000
017700- 'MANDE' to FSOV51-MESSAG
Move 'VALIDER LA DEMANDE REGU INIT ARTICLE PAR F5'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}