import Foundation
let pattern = #"(?i)MOVE.*\n?.*VALIDER.*\n?.*F5"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Move 'VALIDER LA DEMANDE REGU INIT ARTICLE & MAJ TARIF P16910000
017900- 'AR F5' to FSOV51-MESSAG
Move 'DEMANDE REGU TRAITEE, F6 POUR FORCER LA DE16710000
017700- 'MANDE' to FSOV51-MESSAG
Move 'VALIDER LA DEMANDE REGU INIT ARTICLE PAR F5'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)