import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)MOVE.*\\n?.*VALIDER.*\\n?.*F5";
final String string = "Move 'VALIDER LA DEMANDE REGU INIT ARTICLE & MAJ TARIF P16910000\n"
+ "017900- 'AR F5' to FSOV51-MESSAG\n\n"
+ " Move 'DEMANDE REGU TRAITEE, F6 POUR FORCER LA DE16710000\n"
+ "017700- 'MANDE' to FSOV51-MESSAG \n\n\n"
+ " Move 'VALIDER LA DEMANDE REGU INIT ARTICLE PAR F5'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}