use strict;
my $str = 'Move \'VALIDER LA DEMANDE REGU INIT ARTICLE & MAJ TARIF P16910000
017900- \'AR F5\' to FSOV51-MESSAG
Move \'DEMANDE REGU TRAITEE, F6 POUR FORCER LA DE16710000
017700- \'MANDE\' to FSOV51-MESSAG
Move \'VALIDER LA DEMANDE REGU INIT ARTICLE PAR F5\'';
my $regex = qr/(?i)MOVE.*\n?.*VALIDER.*\n?.*F5/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}