$re = '/(?i)MOVE.*\n?.*VALIDER.*\n?.*F5/m';
$str = 'Move \'VALIDER LA DEMANDE REGU INIT ARTICLE & MAJ TARIF P16910000
017900- \'AR F5\' to FSOV51-MESSAG
Move \'DEMANDE REGU TRAITEE, F6 POUR FORCER LA DE16710000
017700- \'MANDE\' to FSOV51-MESSAG
Move \'VALIDER LA DEMANDE REGU INIT ARTICLE PAR F5\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);