#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s).*"
Local $sString = "this" & @CRLF & _
"is" & @CRLF & _
"my" & @CRLF & _
"string"
Local $sSubst = "REPLACEMENT"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)