package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s).*`)
var str = `this
is
my
string`
var substitution = "REPLACEMENT"
fmt.Println(re.ReplaceAllString(str, substitution))
}