import re
regex = re.compile(r".*", flags=re.DOTALL)
test_str = ("this\n"
"is\n"
"my\n"
"string")
subst = "REPLACEMENT"
result = regex.sub(subst, test_str)
if result:
print(result)