const regex = /.*/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*', 'gs')
const str = `this
is
my
string`;
const subst = `REPLACEMENT`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);