#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:<li\b[^>]*>.*?<\/li>))"
Local $sString = "<ol type="A" lang="en-CA" style="margin-bottom: 0in; line-height: 100%">" & @CRLF & _
" <li type="A"><span>Text</span></li>" & @CRLF & _
" <li><span>More text</span></li>" & @CRLF & _
"</ol>" & @CRLF & _
"<ol type="I" style="font-weight: bold;">" & @CRLF & _
" <li><span>Text</span></li>" & @CRLF & _
" <li><span>More text</span></li>" & @CRLF & _
"</ol>" & @CRLF & _
"<ol type="1" style="font-weight: bold;">" & @CRLF & _
" <li><span>Text</span></li>" & @CRLF & _
" <li><span>More text</span></li>" & @CRLF & _
"</ol>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)