import re
regex = re.compile(r"((?:<li\b[^>]*>.*?<\/li>))", flags=re.MULTILINE)
test_str = ("<ol type=\"A\" lang=\"en-CA\" style=\"margin-bottom: 0in; line-height: 100%\">\n"
" <li type=\"A\"><span>Text</span></li>\n"
" <li><span>More text</span></li>\n"
"</ol>\n"
"<ol type=\"I\" style=\"font-weight: bold;\">\n"
" <li><span>Text</span></li>\n"
" <li><span>More text</span></li>\n"
"</ol>\n"
"<ol type=\"1\" style=\"font-weight: bold;\">\n"
" <li><span>Text</span></li>\n"
" <li><span>More text</span></li>\n"
"</ol>")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)