$re = '/((?:<li\b[^>]*>.*?<\/li>))/m';
$str = '<ol type="A" lang="en-CA" style="margin-bottom: 0in; line-height: 100%">
<li type="A"><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type="I" style="font-weight: bold;">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type="1" style="font-weight: bold;">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;