const regex = /((?:<li\b[^>]*>.*?<\/li>))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:<li\\b[^>]*>.*?<\\\/li>))', 'gm')
const str = `<ol type="A" lang="en-CA" style="margin-bottom: 0in; line-height: 100%">
<li type="A"><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type="I" style="font-weight: bold;">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type="1" style="font-weight: bold;">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);