use strict;
my $str = '<ol type="A" lang="en-CA" style="margin-bottom: 0in; line-height: 100%">
<li type="A"><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type="I" style="font-weight: bold;">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type="1" style="font-weight: bold;">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>';
my $regex = qr/((?:<li\b[^>]*>.*?<\/li>))/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";