#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)=> ([A-Z0-9]{6})\)"
Local $sString = "Array([0] => Array([0] => CLASSI[1] => LEATHE[2] => 0MEFCQ))" & @CRLF & _
"" & @CRLF & _
"VANS CLASSIC SLIP-ON CROC LEATHER 0MEFCQ 36-40" & @CRLF & _
"" & @CRLF & _
"([0] => Array([0] => TRAMPK[1] => XH8GKA))" & @CRLF & _
"" & @CRLF & _
"NOWE TRAMPKI VANS SK8-HI SLIM ZIP XH8GKA 36-40" & @CRLF & _
"" & @CRLF & _
"([0] => Array([0] => DAMSKI[1] => TRAMPK[2] => AUTHEN[3] => EE3W00))" & @CRLF & _
"" & @CRLF & _
"DAMSKIE TRAMPKI VANS AUTHENTIC EE3W00 35-41"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")