// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)=> ([A-Z0-9]{6})\)").unwrap();
let string = "Array([0] => Array([0] => CLASSI[1] => LEATHE[2] => 0MEFCQ))
VANS CLASSIC SLIP-ON CROC LEATHER 0MEFCQ 36-40
([0] => Array([0] => TRAMPK[1] => XH8GKA))
NOWE TRAMPKI VANS SK8-HI SLIM ZIP XH8GKA 36-40
([0] => Array([0] => DAMSKI[1] => TRAMPK[2] => AUTHEN[3] => EE3W00))
DAMSKIE TRAMPKI VANS AUTHENTIC EE3W00 35-41";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}