const regex = /=> ([A-Z0-9]{6})\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=> ([A-Z0-9]{6})\\)', 'gm')
const str = `Array([0] => Array([0] => CLASSI[1] => LEATHE[2] => 0MEFCQ))
VANS CLASSIC SLIP-ON CROC LEATHER 0MEFCQ 36-40
([0] => Array([0] => TRAMPK[1] => XH8GKA))
NOWE TRAMPKI VANS SK8-HI SLIM ZIP XH8GKA 36-40
([0] => Array([0] => DAMSKI[1] => TRAMPK[2] => AUTHEN[3] => EE3W00))
DAMSKIE TRAMPKI VANS AUTHENTIC EE3W00 35-41`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}