using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=> ([A-Z0-9]{6})\)";
string input = @"Array([0] => Array([0] => CLASSI[1] => LEATHE[2] => 0MEFCQ))
VANS CLASSIC SLIP-ON CROC LEATHER 0MEFCQ 36-40
([0] => Array([0] => TRAMPK[1] => XH8GKA))
NOWE TRAMPKI VANS SK8-HI SLIM ZIP XH8GKA 36-40
([0] => Array([0] => DAMSKI[1] => TRAMPK[2] => AUTHEN[3] => EE3W00))
DAMSKIE TRAMPKI VANS AUTHENTIC EE3W00 35-41";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}