re = /=> ([A-Z0-9]{6})\)/m
str = 'Array([0] => Array([0] => CLASSI[1] => LEATHE[2] => 0MEFCQ))
VANS CLASSIC SLIP-ON CROC LEATHER 0MEFCQ 36-40
([0] => Array([0] => TRAMPK[1] => XH8GKA))
NOWE TRAMPKI VANS SK8-HI SLIM ZIP XH8GKA 36-40
([0] => Array([0] => DAMSKI[1] => TRAMPK[2] => AUTHEN[3] => EE3W00))
DAMSKIE TRAMPKI VANS AUTHENTIC EE3W00 35-41'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end