#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)I like (?!foo(?!d|tball))[^ ]+"
Local $sString = "I like foo << - not allowed" & @CRLF & _
"I like fooSomeRandomString << - not allowed" & @CRLF & _
"I like food << - allowed" & @CRLF & _
"I like football << - allowed" & @CRLF & _
"I like drawing << - allowed" & @CRLF & _
"I dislike drawing << - not allowed"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")