re = /I like (?!foo(?!d|tball))[^ ]+/m
str = 'I like foo << - not allowed
I like fooSomeRandomString << - not allowed
I like food << - allowed
I like football << - allowed
I like drawing << - allowed
I dislike drawing << - not allowed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end